CRAN Package Check Results for Package Signac

Last updated on 2023-02-04 10:54:47 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.9.0 90.80 405.23 496.03 NOTE
r-devel-linux-x86_64-debian-gcc 1.9.0 71.34 299.73 371.07 NOTE
r-devel-linux-x86_64-fedora-clang 1.9.0 652.85 NOTE
r-devel-linux-x86_64-fedora-gcc 1.9.0 632.56 NOTE
r-devel-windows-x86_64 1.9.0 175.00 579.00 754.00 NOTE
r-patched-linux-x86_64 1.9.0 77.45 370.66 448.11 OK
r-release-linux-x86_64 1.9.0 69.52 382.52 452.04 OK
r-release-macos-arm64 1.9.0 127.00 NOTE
r-release-macos-x86_64 1.9.0 202.00 OK
r-release-windows-x86_64 1.9.0 192.00 471.00 663.00 OK
r-oldrel-macos-arm64 1.9.0 10.00 ERROR
r-oldrel-macos-x86_64 1.9.0 11.00 ERROR
r-oldrel-windows-ix86+x86_64 1.9.0 191.00 701.00 892.00 OK

Check Details

Version: 1.9.0
Check: C++ specification
Result: NOTE
     Specified C++11: please update to current default of C++17
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64

Version: 1.9.0
Check: package dependencies
Result: NOTE
    Imports includes 24 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.9.0
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'chromVAR', 'TFBSTools', 'motifmatchr'
Flavor: r-release-macos-arm64

Version: 1.9.0
Check: Rd cross-references
Result: NOTE
    Packages unavailable to check Rd xrefs: ‘TFBSTools’, ‘motifmatchr’, ‘chromVAR’
Flavor: r-release-macos-arm64

Version: 1.9.0
Check: package dependencies
Result: ERROR
    Package required and available but unsuitable version: ‘GenomeInfoDb’
    
    Packages suggested but not available for checking:
     'chromVAR', 'TFBSTools', 'motifmatchr'
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-arm64

Version: 1.9.0
Check: package dependencies
Result: ERROR
    Package required and available but unsuitable version: ‘GenomeInfoDb’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-x86_64